Discussion:
MBSA remote scanning issue
(too old to reply)
WF-ScanMan
2010-04-01 14:16:01 UTC
Permalink
Raw Message
I am getting the following error when I scan a remote computer:

Computer has an older version of the client and security database demands a
newer version. Current version is and minmum required version is 5.8.0.2678.

Any help is appreciated.

Thx.
Bill Sanderson
2010-04-01 14:43:07 UTC
Permalink
Raw Message
This and many other answers can be found in the MBSA FAQ:

http://technet.microsoft.com/en-us/security/cc184922.aspx

Q: Why am I seeing error "Computer has an older version of the client and
security database demands a newer version"?
This error means that the version of WUA is lower than the minimum required
version stated in wsusscn2.cab. Unless the WUA version is equal or greater
than the version needed by wsusscn2.cab, scanning the computer will return
an error.

To correct this, ensure the latest version of WUA is installed on the target
computer. To have MBSA automatically correct this error, be sure to select
the option to "Configure computers for Microsoft Update and scanning
prerequisites" or use the /ia option in the command-line tool.
Post by WF-ScanMan
Computer has an older version of the client and security database demands a
newer version. Current version is and minmum required version is 5.8.0.2678.
Any help is appreciated.
Thx.
WF-ScanMan
2010-04-01 15:53:02 UTC
Permalink
Raw Message
Thanks for the response- The PC already has the newest WUA. Now I am
getting this error when scanning that PC - "An error occurred while scanning
for security updates. (0x800706aa)"
Post by Bill Sanderson
http://technet.microsoft.com/en-us/security/cc184922.aspx
Q: Why am I seeing error "Computer has an older version of the client and
security database demands a newer version"?
This error means that the version of WUA is lower than the minimum required
version stated in wsusscn2.cab. Unless the WUA version is equal or greater
than the version needed by wsusscn2.cab, scanning the computer will return
an error.
To correct this, ensure the latest version of WUA is installed on the target
computer. To have MBSA automatically correct this error, be sure to select
the option to "Configure computers for Microsoft Update and scanning
prerequisites" or use the /ia option in the command-line tool.
Post by WF-ScanMan
Computer has an older version of the client and security database demands a
newer version. Current version is and minmum required version is 5.8.0.2678.
Any help is appreciated.
Thx.
Bill Sanderson
2010-04-01 16:25:18 UTC
Permalink
Raw Message
I'd look at firewalls or proxy settings on the target machine--but I don't
find this covered in the FAQ, and can't recall having seen it myself.

The faq does have:

Q: Why am I seeing error "An error occurred while scanning for security
updates. (0x80244019)"?
This error indicates that the Windows Update Agent was not able to
communicate with the assigned Update Services server because of proxy
configuration setting on the target computer. If a proxy server is in use,
check the target computer's Internet Explorer Internet Options settings and
ensure the Update Services server is in the proxy bypass list using either
the Bypass proxy server for local addresses setting, or using the Advanced
button in the exception list. Using the proxy bypass allows end-users to
access the Internet via the proxy server, yet directly access local intranet
servers. This is also needed to allow WUA to contact the WSUS server on the
local network.

which is worth investigating, in case this is a variation on that issue.
Post by WF-ScanMan
Thanks for the response- The PC already has the newest WUA. Now I am
getting this error when scanning that PC - "An error occurred while scanning
for security updates. (0x800706aa)"
Post by Bill Sanderson
http://technet.microsoft.com/en-us/security/cc184922.aspx
Q: Why am I seeing error "Computer has an older version of the client and
security database demands a newer version"?
This error means that the version of WUA is lower than the minimum required
version stated in wsusscn2.cab. Unless the WUA version is equal or greater
than the version needed by wsusscn2.cab, scanning the computer will return
an error.
To correct this, ensure the latest version of WUA is installed on the target
computer. To have MBSA automatically correct this error, be sure to select
the option to "Configure computers for Microsoft Update and scanning
prerequisites" or use the /ia option in the command-line tool.
Post by WF-ScanMan
Computer has an older version of the client and security database
demands
a
newer version. Current version is and minmum required version is 5.8.0.2678.
Any help is appreciated.
Thx.
Loading...